Loading
Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more

crowdAI is shutting down - please read our blog post for more information

NIPS 2017: Learning to Run

Reinforcement learning environments with musculoskeletal models


Completed
2154
Submissions
630
Participants
91688
Views

Server Error

Posted by VsonicV about 2 years ago

I have been trying to submit my agent several times today, but always got an osim.http.client.ServerError during the second episode. Is this a common issue with the server today? Thanks!

1

Posted by pg  about 2 years ago |  Quote

I have been having exactly the same issue today. Would be really grateful if this issue could be addressed.

1

Posted by Yongjin  about 2 years ago |  Quote

I have been having the same trouble today.

Posted by spMohanty  about 2 years ago |  Quote

Hi everyone,

Can you guys try again and let us know if you are still facing this issue ?

Note that it is unlikely issues like this will persist in the second round, as each of you will be provided a separate instance to grade your submission through the whole week. And atleast that will rule out submission failure due to resource hogging by other parallel submissions.

Posted by spMohanty  about 2 years ago |  Quote

This comment has been redacted by the administrator

Posted by VsonicV  about 2 years ago |  Quote

I have tried once more this morning, and got the same error during the third episode

Posted by M.Lehmann  about 2 years ago |  Quote

same here: _parse_server_error_or_raise_for_status

File “/…/python2.7/site-packages/osim/http/client.py”, line 33, in _parse_server_error_or_raise_for_status raise ServerError(message=j[“message”], status_code=resp.status_code) osim.http.client.ServerError

Process finished with exit code 1

Posted by Yongjin  about 2 years ago |  Quote

I tried again and got the same error at the same point during the second episode.

Posted by linzichuan  about 2 years ago |  Quote

I tried again and also got the same error during the third episode.

Posted by USTC-IMCL  about 2 years ago |  Quote

I have another issue today, it raised ConnectionError instead of ServerError like before. Here is the fault info in detail: /requests/adapters.py”, line 490, in send raise ConnectionError(err, request=request) requests.exceptions.ConnectionError: (‘Connection aborted.’, BadStatusLine(“’’”,))

Posted by amcleod  about 2 years ago |  Quote

I’m also getting this error. I haven’t been able to submit for over 24 hours.

Posted by THU_JGeek  about 2 years ago |  Quote

Same issue. Looks running well at the beginning, but always stop in the middle, like 500-700 steps. requests.exceptions.HTTPError: 502 Server Error: Bad Gateway for url: http://grader.crowdai.org:1729/v1/envs/…

Posted by THU_JGeek  about 2 years ago |  Quote

Also another issue.

raise ServerError(message=j[“message”], status_code=resp.status_code) osim.http.client.ServerError

Posted by Megvii-hzwer  about 2 years ago |  Quote

I haven’t been able to submit for several days。。。

Posted by spMohanty  about 2 years ago |  Quote

Hi everyone,

Can you drop a line on the gitter channel ( https://gitter.im/crowdAI/NIPS-Learning-To-Run-Challenge ), so that we can coordinate the submissions in realtime and try to see whats the exact issue. I am able to submit solutions. And as you can see in the Daily Digest, about 17 submissions were successfully made in the last 24 hours; so the issue could be specific to certain submissions. A realtime communication could help debug the situation more.

If you have a submission which doesnt work deterministically everytime, it would be great if you can somehow send it to us at : sharada.mohanty@epfl.ch

1

Posted by Yujin  about 2 years ago |  Quote

Hi everyone,

Can you drop a line on the gitter channel ( https://gitter.im/crowdAI/NIPS-Learning-To-Run-Challenge ), so that we can coordinate the submissions in realtime and try to see whats the exact issue. I am able to submit solutions. And as you can see in the Daily Digest, about 17 submissions were successfully made in the last 24 hours; so the issue could be specific to certain submissions. A realtime communication could help debug the situation more.

If you have a submission which doesnt work deterministically everytime, it would be great if you can somehow send it to us at : sharada.mohanty@epfl.ch

Just emailed you my submission log, it contains actions so you should be able to reproduce (non-deterministic though).

Posted by Yongjin  about 2 years ago |  Quote

I still get the same error during the second episode, but at a bit different point.

The deadline is near and I have not been able to submit with my latest model for serval days and get some feedbacks from the grader.

I hope that the problem gets solved soon or the admin extends the due.

Posted by VsonicV  about 2 years ago |  Quote

I just made one submission, and it finally succeeds…

Posted by linzichuan  about 2 years ago |  Quote

Sigh… It always crashed in my third submission…

Posted by THU_JGeek  about 2 years ago |  Quote

After the update yesterday, I can just finish 1st episode only one time then fail in 2nd episode. It always crashed in 1st episode though I write a script to submit my model automatically when meeting errors like 502 server error, JSONDecodeError, etc. Sigh.

Posted by spMohanty  about 2 years ago |  Quote

Hi everyone,

Just announced a grading server downtime to deal with this issue. More on this here : https://www.crowdai.org/topics/server-downtime/comments/new

Posted by spMohanty  about 2 years ago |  Quote

The grading server is back online, and details are posted in the update on this post : https://www.crowdai.org/topics/server-downtime/comments/new