Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more

crowdAI is shutting down - please read our blog post for more information

Learning How to Walk

Reinforcement learning environments with musculoskeletal models


Installing from source

Posted by tr1pzz about 3 years ago


I tried installing everything from source (in stead of using conda) and am running into some issues: I was able to compile and install everything well I think, and then I ran the following test script to test everything:

from osim.env import GaitEnv import numpy as np import gym

env = GaitEnv(visualize=False) observation = env.reset()

for i in range(5000): action = env.action_space.sample() shape = action.shape action = np.zeros(shape) observation, reward, done, info = env.step(action) print(reward,done) if done: env.reset()

Everything seems OK until env.reset() it seems like this method is not exactly working correctly because after it my terminal starts dumping this error message endlessly:

(-500, True) std::exception in ‘bool OpenSim::Manager::integrate(SimTK::State &)’: SimTK Exception thrown at AbstractIntegratorRep.cpp:428: Integrator step failed at time 1.5600000000000001 apparently because: SimTK Exception thrown at AbstractIntegratorRep.cpp:547: Error detected by Simbody method AbstractIntegrator::takeOneStep(): Unable to advance time past 1.56. (Required condition ‘t1 > t0’ was not met.)

If I run this in terminal (in stead of Ipython notebook) and set visualise=True I get the following error message and everything hangs: simbody-visualizer: error while loading shared libraries: libSimTKcommon.so.3.6: cannot open shared object file: No such file or directory

Any ideas as to what part of my installation went wrong / is missing?


Posted by Lukasz_  about 3 years ago |  Quote

Hi, thanks for your input and sorry for the late answer. Regarding the problem with integration, it often relates to sending NULLs as an action. Another reason could be using some intermediate version of OpenSim - please use the commit b3163b22be7bd4cccd8c073e02dd3abb52867031 (alpha version of OpenSim 4.0 is changing very quickly so we have a fixed commit for the competition).

Regarding the library, please try to link the simbody libraries to your /usr/lib or other library directory.

Please let us know if it helps,

Best, Łukasz