Loading
Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more

crowdAI is shutting down - please read our blog post for more information

NIPS 2017: Learning to Run

Reinforcement learning environments with musculoskeletal models


Completed
2154
Submissions
631
Participants
88626
Views

Error when trying to run code in container

Posted by jzl_2017 over 1 year ago

I am getting the following error when I am trying to run my agent code in the docker provided:

Traceback (most recent call last): File “./main.py”, line 9, in from domains.domains import DOMAINS File "/home/nipsrunning/framework/domains/domains.py", line 5, in from nipsrunning import NipsRunning File "/home/nipsrunning/framework/domains/nipsrunning.py", line 3, in from osim.env import RunEnv File "/opt/conda/envs/opensim-rl/lib/python2.7/site-packages/osim/env/__init__.py", line 2, in from .run import * File "/opt/conda/envs/opensim-rl/lib/python2.7/site-packages/osim/env/run.py", line 1, in import opensim File "/opt/conda/envs/opensim-rl/lib/python2.7/site-packages/opensim/__init__.py", line 1, in from simbody import * File "/opt/conda/envs/opensim-rl/lib/python2.7/site-packages/opensim/simbody.py", line 28, in _simbody = swig_import_helper() File "/opt/conda/envs/opensim-rl/lib/python2.7/site-packages/opensim/simbody.py", line 24, in swig_import_helper _mod = imp.load_module('_simbody', fp, pathname, description) ImportError: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/conda/envs/opensim-rl/lib/python2.7/site-packages/opensim/_simbody.so)

Posted by VsonicV  over 1 year ago |  Quote

I struggled with the same issue, and this problem can be solved by simply moving “import opensim as osim” to the first line, before importing any other packages. I have posted this solution in the official gitter channel, should have checked the forum and told you earlier……