Loading
Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more

crowdAI is shutting down - please read our blog post for more information

Train Schedule Optimisation Challenge

Optimizing train schedules


Completed
209
Submissions
444
Participants
29671
Views

Connection times not validated?

Posted by iquadrat about 1 year ago

I just submitted a solution that does not fulfill the minimum connection times for instance 04. It got accepted as feasible solution anyways. Is there a problem with the validator?

Posted by jordiju  about 1 year ago |  Quote

Should not, but I can’t rule it out. Can you send me the solution to julian.jordi@sbb.ch

Thanks!

Posted by Palstek  about 1 year ago |  Quote

Second that. So far, I was not able to produce connection errors with neither the validation tool nor the actual submission tool.

Posted by jordiju  about 1 year ago |  Quote

Hi guys

Indeed connection errors were not detected. The problem was that the solution validator got updated by mistake, and since we started the challenge the data format has changed. It therefore did not check for “connections” since that element does not exist anymore.

We have restored the correct version. I now get connection errors (although for the moment, they are not translated into english yet, it seems): Errors: - Anschlusszeit PT2M30S unterschritten for Anschluss 5059[WAE_Halt]{06:32:35.100} on 19322[WAE_Halt]{06:34}

@iquadrat , @Palstek : Can you verify that you now also get these validation errors?

Thanks for pointing this out!

Posted by iquadrat  about 1 year ago |  Quote

Still don’t get any errors for my bad solution. Sent it to you by mail.

Posted by jordiju  about 1 year ago |  Quote

@iquadrat @Palstek : It flipped back to the new version. Should be ok now. Please try again. I now get Errors: - Anschlusszeit PT2M30S unterschritten for Anschluss 18823[WAE_Halt]{07:07:05} on 19324[WAE_Halt]{07:09}

Posted by Palstek  about 1 year ago |  Quote

Yep, now it works!

Posted by iquadrat  about 1 year ago |  Quote

Confirmed, it works now.

Posted by Raphael  about 1 year ago |  Quote

@Must @Palstek and @tdschweiz With the bug fixed your submitted solutions in the leader board don’t correctly reflect the reality. In reality they all have a score of 60’000+. I will therefor delete those submissions, but feel free uploading them again.