Loading
Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more

crowdAI is shutting down - please read our blog post for more information

NIPS 2017: Learning to Run

Reinforcement learning environments with musculoskeletal models


Completed
2154
Submissions
630
Participants
91689
Views

Can't update, pip hangs on git clone

Posted by Edmund_Ronald over 2 years ago

on os x …

trying to update for new reward.

anyone solved this?

Posted by Edmund_Ronald  over 2 years ago |  Quote

$ pip install git+https://github.com/stanfordnmbl/osim-rl.git -U Collecting git+https://github.com/stanfordnmbl/osim-rl.git Cloning https://github.com/stanfordnmbl/osim-rl.git to /private/var/folders/_3/3y7l739x5gg5ztv4wlf3rx7w0000gn/T/pip-wPZL5i-build

Posted by Edmund_Ronald  over 2 years ago |  Quote

Here is another log - I changed the git protocol and it hangs again after working a bit

(opensim-rl) Edmunds-MBP:~ edmundronald$ pip install git+git://github.com/stanfordnmbl/osim-rl.git -U Collecting git+git://github.com/stanfordnmbl/osim-rl.git Cloning git://github.com/stanfordnmbl/osim-rl.git to /private/var/folders/_3/3y7l739x5gg5ztv4wlf3rx7w0000gn/T/pip-ATG9wS-build Requirement already up-to-date: numpy in /anaconda/envs/opensim-rl/lib/python2.7/site-packages (from osim-rl==1.4.1) Requirement already up-to-date: gym in /anaconda/envs/opensim-rl/lib/python2.7/site-packages (from osim-rl==1.4.1) Requirement already up-to-date: pyglet>=1.2.0 in /anaconda/envs/opensim-rl/lib/python2.7/site-packages (from gym->osim-rl==1.4.1) Collecting requests>=2.0 (from gym->osim-rl==1.4.1) Using cached requests-2.18.3-py2.py3-none-any.whl Requirement already up-to-date: six in /anaconda/envs/opensim-rl/lib/python2.7/site-packages (from gym->osim-rl==1.4.1) Requirement already up-to-date: chardet<3.1.0,>=3.0.2 in /anaconda/envs/opensim-rl/lib/python2.7/site-packages (from requests>=2.0->gym->osim-rl==1.4.1) Requirement already up-to-date: certifi>=2017.4.17 in /anaconda/envs/opensim-rl/lib/python2.7/site-packages (from requests>=2.0->gym->osim-rl==1.4.1) Requirement already up-to-date: idna<2.6,>=2.5 in /anaconda/envs/opensim-rl/lib/python2.7/site-packages (from requests>=2.0->gym->osim-rl==1.4.1) Requirement already up-to-date: urllib3<1.23,>=1.21.1 in /anaconda/envs/opensim-rl/lib/python2.7/site-packages (from requests>=2.0->gym->osim-rl==1.4.1) Installing collected packages: osim-rl, requests Found existing installation: osim-rl 1.4.1 Uninstalling osim-rl-1.4.1: Successfully uninstalled osim-rl-1.4.1 Running setup.py install for osim-rl … -

Posted by spMohanty  over 2 years ago |  Quote

@Edmund Ronald : Is this solved ? Can you also try this on another machine ?

It would also be great if you provide some information on the environment you are trying this out in.

1

Posted by Edmund_Ronald  over 2 years ago |  Quote

Thank you for responding.

This was on a Mac, had a similar issue on Linux.

I solved it in the end by figuring out that the prescribed conda install process for opensim-rl loads an incorrect git on the system; so git gets broken, one should do afterwards

“conda update git “ within the opensim-rl environment.

Edmund

PS. People on this discussion are being more competitive than collegial. This is a sad and no fun way to spend a month,, and maybe crowdai competition rules should be changed to be less winner/loser and more let’s have fun together.

@Edmund Ronald : Is this solved ? Can you also try this on another machine ?

It would also be great if you provide some information on the environment you are trying this out in.

1

Posted by Marcel_Salathé  about 2 years ago |  Quote

Hi Edmund

Thanks for your comments about people on this discussion being more competitive than collegial. Can you elaborate a bit? Do you mean the fact that there were no immediate responses, or were there competitive posts that were deleted?

If the former, then this is probably related to an issue that we had with the email server, and that is being fixed. The problem was that no emails were being sent, which then led to little activity on the board. Very sorry about that, and a fix is about to be deployed very shortly.

But beyond, if you have any recommendations about how to make crowdAI more collegial, please let us know! We’re eager to make this a place where people can work together.

1

Posted by Edmund_Ronald  about 2 years ago |  Quote

Hello Marcel,

Look at the number of participants, look at the number of submissions, and then look at the forum activity, and you can see that people are working but not sharing. Making it advantageous for participants to share, eg by having a forum upvote system with prizes for people who answer tech questions on the forum might benefit anyone - eg. give people some AWS time for forum participation - they can go mine bitcoin with it if they want, or improve their scores or whatever, but I personally would not complain if someone who has taken pains to look at the sim code and eg. shares code snippets to save and reload configurations or create run videos etc. is rewarded with some added computer time or gets an amazon voucher for a book or a pair of headphones. Note that someone with the tech skills to participate, and living in the US or the richer European countries could probably work 20 hours and buy a PC that would run rings around my home system.

Edmund

Hi Edmund

Thanks for your comments about people on this discussion being more competitive than collegial. Can you elaborate a bit? Do you mean the fact that there were no immediate responses, or were there competitive posts that were deleted?

If the former, then this is probably related to an issue that we had with the email server, and that is being fixed. The problem was that no emails were being sent, which then led to little activity on the board. Very sorry about that, and a fix is about to be deployed very shortly.

But beyond, if you have any recommendations about how to make crowdAI more collegial, please let us know! We’re eager to make this a place where people can work together.

1